Dhcp failed apipa is being used cisco ошибка

So, I have the following network configuration in Packet Tracer.Network configuration

The router is configured with DHCP. The ports on the switches are configured with access mode — for those that belong to the PCs. The unused ports are shut down. The ports between the switches and the ports between the switch and the router are configured as trunk ports. All the PCs that are connected to the S1 that is directly connected to the R1 get the IP addresses from the router. However, the PCs that are connected to the S2 and S3 don’t — instead they get the message «DHCP request failed, APIPA being used». What could be the problem?

Here is the link for the configurations — https://1drv.ms/u/s!AiRtffZ-QpFphY8iof_YGdcuua3KXw

The configurations for R1:

ip dhcp pool Head  
 network 10.10.10.0 255.255.255.0  
 default-router 10.10.10.1  
ip dhcp pool R&D  
 network 10.10.20.0 255.255.255.0  
 default-router 10.10.20.1  
ip dhcp pool M&S  
 network 10.10.30.0 255.255.255.0  
 default-router 10.10.30.1  
ip dhcp pool Lab  
 network 10.10.40.0 255.255.255.0  
 default-router 10.10.40.1  
ip dhcp pool WS  
 network 10.10.50.0 255.255.255.0  
 default-router 10.10.50.1  

no ip cef  
no ipv6 cef  

spanning-tree mode pvst  

interface FastEthernet0/0  
 no ip address  
 ip nat inside  
 duplex auto  
 speed auto  
!  
interface FastEthernet0/0.1  
 encapsulation dot1Q 1 native  
 ip address 10.10.1.1 255.255.255.0  
!  
interface FastEthernet0/0.10  
 encapsulation dot1Q 10  
 ip address 10.10.10.1 255.255.255.0  
!  
interface FastEthernet0/0.20  
 encapsulation dot1Q 20  
 ip address 10.10.20.1 255.255.255.0  
!  
interface FastEthernet0/0.30  
 encapsulation dot1Q 30  
 ip address 10.10.30.1 255.255.255.0  
!  
interface FastEthernet0/0.40  
 encapsulation dot1Q 40  
 ip address 10.10.40.1 255.255.255.0  
!  
interface FastEthernet0/0.50  
 encapsulation dot1Q 50  
 ip address 10.10.50.1 255.255.255.0  
!  
interface FastEthernet0/0.99  
 encapsulation dot1Q 99  
 ip address 10.10.99.1 255.255.255.0  
!  
interface FastEthernet0/1  
 ip address 85.143.163.237 255.255.255.0  
 ip nat outside  
 duplex auto  
 speed auto  

interface Vlan1  
 no ip address  
 shutdown  

ip nat inside source list 1 interface FastEthernet0/1 overload  
ip classless  

ip flow-export version 9  

access-list 1 permit 10.10.0.0 0.0.255.255  

line con 0  

line aux 0  

line vty 0 4  
 login  

The configuration for S1:

spanning-tree mode pvst  
!  
interface FastEthernet0/1   
 switchport mode trunk  
!  
interface FastEthernet0/2  
 switchport mode trunk  
!  
interface FastEthernet0/3  
 shutdown  
!  
interface FastEthernet0/4  
 switchport mode trunk  
!  
interface FastEthernet0/5  
 shutdown  
!  
interface FastEthernet0/6  
 shutdown  
!  
interface FastEthernet0/7  
 shutdown   
!  
interface FastEthernet0/8  
 shutdown  
!  
interface FastEthernet0/9  
 shutdown  
!  
interface FastEthernet0/10  
 switchport access vlan 20  
 switchport mode access  
 spanning-tree portfast  
!  
interface FastEthernet0/11   
 switchport access vlan 20  
 switchport mode access  
 spanning-tree portfast  
!  
interface FastEthernet0/12  
 switchport access vlan 20  
 switchport mode access  
 spanning-tree portfast  
!  
interface FastEthernet0/13  
 switchport access vlan 20  
 switchport mode access  
 spanning-tree portfast  
!  
interface FastEthernet0/14  
 switchport access vlan 20  
 switchport mode access  
 spanning-tree portfast  
!  
interface FastEthernet0/15  
 switchport access vlan 10  
 switchport mode access  
 spanning-tree portfast  
!  
interface FastEthernet0/16  
 switchport access vlan 10  
 switchport mode access  
 spanning-tree portfast  
!  
interface FastEthernet0/17  
 switchport access vlan 30  
 switchport mode access  
 spanning-tree portfast  
!  
interface FastEthernet0/18  
 switchport access vlan 30  
 switchport mode access  
 spanning-tree portfast  
!  
interface FastEthernet0/19  
 switchport access vlan 30  
 switchport mode access  
 spanning-tree portfast  
!  
interface FastEthernet0/20  
 switchport access vlan 30  
 switchport mode access  
 spanning-tree portfast  
!  
interface FastEthernet0/21  
 switchport access vlan 20  
 switchport mode access  
 spanning-tree portfast  
!  
interface FastEthernet0/22  
 switchport access vlan 20  
 switchport mode access  
 spanning-tree portfast  
!  
interface FastEthernet0/23  
 switchport access vlan 30  
 switchport mode access  
 spanning-tree portfast  
!  
interface FastEthernet0/24  
 shutdown  
!  
interface Vlan1  
 no ip address  
 shutdown  
!  
interface Vlan99  
 ip address 10.10.99.10 255.255.255.0  
!  
ip default-gateway 10.10.99.1  

line con 0  
!  
line vty 0 4  
 login  
line vty 5 15  
 login  
!  

The configurations for S2:

spanning-tree mode pvst  
!  
interface FastEthernet0/1  
 shutdown  
!  
interface FastEthernet0/2  
 switchport mode trunk  
!  
interface FastEthernet0/3  
 switchport mode trunk  
!  
interface FastEthernet0/4  
 shutdown  
!  
interface FastEthernet0/5  
 shutdown  
!  
interface FastEthernet0/6  
 shutdown  
!  
interface FastEthernet0/7  
 shutdown  
!  
interface FastEthernet0/8  
 shutdown  
!  
interface FastEthernet0/9  
 shutdown  
!  
interface FastEthernet0/10  
 switchport access vlan 40  
 switchport mode access  
 spanning-tree portfast  
!  
interface FastEthernet0/11  
 switchport access vlan 40  
 switchport mode access  
 spanning-tree portfast  
!  
interface FastEthernet0/12  
 switchport access vlan 40  
 switchport mode access  
 spanning-tree portfast  
!  
interface FastEthernet0/13  
 switchport access vlan 40  
 switchport mode access  
 spanning-tree portfast  
!  
interface FastEthernet0/14  
 switchport access vlan 40  
 switchport mode access  
 spanning-tree portfast  
!  
interface FastEthernet0/15  
 switchport access vlan 40  
 switchport mode access  
 spanning-tree portfast  
!  
interface FastEthernet0/16  
 shutdown  
!  
interface FastEthernet0/17  
 shutdown  
!  
interface FastEthernet0/18   
 shutdown  
!  
interface FastEthernet0/19  
 shutdown  
!  
interface FastEthernet0/20  
 shutdown  
!  
interface FastEthernet0/21  
 shutdown  
!  
interface FastEthernet0/22  
 shutdown  
!  
interface FastEthernet0/23  
 shutdown  
!  
interface FastEthernet0/24  
 shutdown  
!  
interface Vlan1  
 no ip address  
 shutdown  
!  
interface Vlan99  
 ip address 10.10.99.20 255.255.255.0  
!  
ip default-gateway 10.10.99.1  

line con 0  
!  
line vty 0 4  
 login  
line vty 5 15  
 login  
!  

The configurations for S3:

spanning-tree mode pvst  
!  
interface FastEthernet0/1  
 shutdown  
!  
interface FastEthernet0/2  
 shutdown  
!  
interface FastEthernet0/3  
!  
interface FastEthernet0/4  
!  
interface FastEthernet0/5  
 shutdown  
!  
interface FastEthernet0/6  
 shutdown  
!  
interface FastEthernet0/7  
 shutdown  
!  
interface FastEthernet0/8  
 shutdown  
!  
interface FastEthernet0/9  
 shutdown  
!  
interface FastEthernet0/10  
 switchport access vlan 50  
 switchport mode access  
 spanning-tree portfast  
!  
interface FastEthernet0/11  
 switchport access vlan 50  
 switchport mode access  
 spanning-tree portfast  
!  
interface FastEthernet0/12  
 shutdown  
!  
interface FastEthernet0/13  
 shutdown  
!  
interface FastEthernet0/14  
 shutdown  
!  
interface FastEthernet0/15  
 shutdown  
!  
interface FastEthernet0/16  
 shutdown  
!  
interface FastEthernet0/17  
 shutdown  
!  
interface FastEthernet0/18  
 shutdown  
!  
interface FastEthernet0/19  
 shutdown  
!  
interface FastEthernet0/20   
 shutdown  
!  
interface FastEthernet0/21  
 shutdown  
!  
interface FastEthernet0/22  
 shutdown  
!  
interface FastEthernet0/23  
 shutdown  
!  
interface FastEthernet0/24  
 shutdown  
!  
interface Vlan1  
 no ip address  
 shutdown  
!  
interface Vlan99  
 ip address 10.10.99.30 255.255.255.0  
!  
ip default-gateway 10.10.99.1  

line con 0  
!  
line vty 0 4  
 login  
line vty 5 15  
 login  
!  

Hi to all,
In a Cisco packet tracer while i am trying to connect the dhcp server to pc it will getting the error like dhcp failed. APIPA is being used.

For this issues this is also one reason.dhcp is not configured correctly.

If we create a  vlan’s in the switch’s and we configured dhcp server in the layer 3 switch or layer 2 switch or in router.
VLAN 10
NAME SALES
VLAN 20
NAME DATA
We created two vlan’s now creating dhcp server for that 
Switch(config)#ip dhcp pool name sales (should be the vlan name. not any other name.)
Switch(Dhcp-config)#network 192.168.10.0 255.255.255.0
 Switch(dhcp-config)#default-router 192.168.10.1
Switch(dhcp-config)#exit
Swithc(config)#ip dhcp pool name data
Switch(dhcp-config)#network 192.168.20.0 255.255.255.0
Switch(dhcp-config)#default-router 192.168.20.1
Switch(dhcp-config)#exit

dhcp failed apipa is being used
dhcp failed apipa is being used

What is DHCP?

Before we actually get into what the “DHCP failed, APIPA is being used” message means and what steps you need to take to fix it, let us first explain what DHCP is.

DHCP is short for Dynamic Host Configuration Protocol, and it’s a network management protocol in which different devices connected to the network are automatically assigned with different IP Addresses and other related configuration information.

It’s a feature that most modern routers and modems have, and it allows you to have much better network traffic management, stability, and overall, better performance throughout.

You might be wondering what happens if the DHCP option on your router isn’t working for some reason. If that’s the case, you will probably run into a few issues with your connection.

You might notice that some of your devices aren’t able to connect to your network. To get them to connect to your network, you will have to configure a static IP address on the device, and you would have to do that manually for every device you want to connect.

If you’re having issues with the DHCP on your router, you will probably get a “DHCP failed, APIPA is being used” message on your computer, signaling that it switched to the APIPA feature. This will usually be accompanied by some network connectivity issues.

APIPA is an abbreviation for Automatic Private IP Addressing. It’s a feature that some operating systems have that allows your computer to automatically self-configure the IP address when the DHCP isn’t available.

So, if you’ve noticed such message on your computer, it’s because something is wrong with the DHCP option on your router. In the meantime, the APIPA feature will assist your computer in connecting to the network – but your other devices might not be able to do the same.

Luckily, we’re here to help you fix this error so that you don’t have to manually configure the IP addresses for all of your devices.

How Do I Fix It?

  1. Power Cycle Your Router

Power Cycle Your Router

If you’re having issues with the DHCP feature on your router, the first thing you will want to try is to power cycle the router. You could be dealing with a variety of different bugs or errors on your router that could be causing all sorts of issues with your network, including the DHCP one.

If this is the case, by restarting the router, you will be getting rid of those bugs, and as a result, your DHCP will start working again.

It’s pretty easy to power cycle your router. All you need to do is take all of the cables out of your router, including the power cable. Once you take them out, wait for about a minute or two before you plug them back in.

This will completely restart your router, getting rid of all bugs and glitches that you might have had on it. After this, the DHCP issue should be gone, and you should be able to connect to your network again.

  1. Check The DHCP Status

Another thing we suggest that you do is check the status of the DHCP feature on your router. It’s not impossible that the DHCP option has gotten disabled somehow on your router without you being aware of it. So, you will need to make sure that this option is enabled.

To enable this feature, you will have to access the routers admin panel and go to advanced network settings. You should be able to find the DHCP option somewhere in those settings. When you find it check if it’s enabled, and if it’s not, click on the button to switch it on.

Once you have done that, make sure to save your settings and restart your router. After that, the changes you’ve made in the settings will be applied to your network and you will no longer have issues with your connection.

  1. Update The Firmware

Most modern routers have their own firmware that requires regular updating. These updates are necessary for getting rid of any bugs or errors as well as for getting new features on your router and improving the overall quality of the network.

They are released by the manufacturers, and you should download them as soon as they come out.

We recommend setting the router to automatically download and install updates, so you don’t have to worry about it. But if you are having issues with the DHCP on your router, it’s possible that you missed some important update on the firmware.

To check if this is the case, you will have to access the router admin panel once again. There you can check if there are any new updates available and then install them if there are. Your DHCP issue should be solved once you’ve updated the firmware.

  1. Reset Your Router

Finally, if none of the methods we mentioned above have worked for you and you’re still left with the ”DHCP failed, APIPA is being used” message, then there’s nothing else to try but to reset your router.

We know that resetting the router might be a tedious job because you have to configure your router from scratch, but it might be able to solve the DHCP issue that you have.

By resetting the router, you will get rid of all the issues that are caused by the current configuration of the router and you will be able to connect to your network normally again.

RobotPoweredHome is reader-supported. When you buy through links on my blog, I may earn an affiliate commission. As an Amazon Associate, I earn from qualifying purchases.

I have a batch script that I run every once in a while that reconfigures my computer’s connection with the router.

I made this script so that I don’t have to type in the commands or remember them whenever needed.

I ran the batch file a few days back like I usually do, but when I executed it, the Command Prompt window notified me of an error that said, “DHCP Failed, APIPA is being used.”

I don’t use a static IP and have DHCP on, which would mean that there was some issue with my router’s configuration.

I went online and checked out a few networking forums and my router’s support documentation to find out more.

I managed to find a load of fixes, some easy and some pretty advanced, so I sat down in front of my computer to troubleshoot.

Thanks to several hours of research, I was able to fix my router, and my script ran successfully.

This article summarizes my findings and should help fix your network when you get a DHCP failed error in seconds.

The DHCP Failed APIPA is being used message means that DHCP is currently not working, and the device has defaulted to using APIPA to assign IP addresses. Either use a static IP or turn DHCP on to fix this issue.

Find out in the article what APIPA is and how IP addresses are assigned to devices on your local network and the internet.

Use A Static IP

DHCP is the protocol that issues IP addresses to the devices on your network after a set time or whenever a network change occurs, like a restart or a reset.

If you want to use a Static IP for the devices on your network, you’ll have DHCP turned off.

So after turning DHCP off, assign the Static IPs that the devices connecting to your network can use.

If these aren’t provided, the router cannot establish the connection within the network, which can cause the error you’re seeing now.

After assigning the Static IPs, check if the error comes back again at where you saw it for the time.

Turn DHCP On

Your router defaults to using APIPA or Automatic IP Addressing when it can’t access the DHCP server.

Turning off DHCP in your router settings will block the router from connecting to the DHCP server, and it defaults to using APIPA.

You can turn DHCP on from your Windows PC and your router.

Consult your router’s manual to find out how you can turn DHCP on with its admin interface.

To turn DHCP on Windows:

  1. Open Settings.
  2. Go to Network & Internet.
  3. For Wi-Fi, select Wi-Fi, then Manage known networks. Select the router that you want to turn DHCP on.
  4. For ethernet, click Ethernet, then the network you’re connected to.
  5. Click Edit, under IP Assignment.
  6. Under Edit Network Settings, click. Automatic (DHCP).
  7. Hit Save.

After you turn DHCP on, see if the error comes up again.

You can experiment with keeping DHCP on either your PC or your router if enabling both doesn’t seem to fix the error.

Update Router Firmware

DHCP and other configuration settings are purely software and used to manage the connections to the router, which makes it easier for you or network admins who monitor the network.

If your router’s firmware is outdated or hasn’t been updated in a while, bugs can creep up that might haven’t appeared if you kept its software updated.

The only part of the router that you can update is the firmware, which requires you to log in to your router’s admin interface.

Follow these steps to install the latest firmware on your router:

  1. Go to the support website of your router.
  2. Look for firmware updates for your exact model. You can also go to the community forums to do this.
  3. Download the file and extract the file’s contents into somewhere you remember.
  4. Open a new web browser tab.
  5. Type 192.168.1.1 in the address bar and hit enter.
  6. Log in to the tool with your username and password. If you haven’t set one, check underneath the router. The password would be on a sticker.
  7. Go to Administration or Advanced, or use the search function to find the update page if the tool has it. Consult the manual of your router for the exact location.
  8. Upload the file you had extracted before.
  9. Install the new firmware.
  10. The router will restart and be ready for use when it turns back on.

See if you get the error message again after installing the update to the router’s firmware.

Restart Router

When even a software update fails to fix the issue, its time to take out the most helpful tool in any troubleshooter’s arsenal, the device restart.

Restarts enjoy high success rates because you are soft resetting the device, mainly if you power cycle the device during the restart.

Soft resets don’t affect your settings or other configurations, but they fix many issues because it clears the device’s onboard memory.

To restart or power cycle your router:

  1. Turn the router off.
  2. Unplug it from the wall outlet.
  3. Wait for a minimum of 1 minute before you connect the device back to power.
  4. Turn the router back on.

When the router turns on, check where you saw the error the first time and see if it repeats after the restart.

Reset Router

A restart isn’t the be-all-end-all of troubleshooting, though; we still have the nuclear option left, which is the factory reset.

I call this nuclear because it wipes everything from the router, including your custom settings, the funny name that your Wi-Fi has, and the password you use to connect to it.

Don’t worry; you still can access the router after the reset; you just have to set everything up again like it was before the reset.

To reset your router:

  1. Locate the reset button on the back of the router. It should be recessed and labeled Reset.
  2. Use a pointed non-metallic object to press and hold the button for 30 seconds.
  3. The router will restart when the button is held for the right amount of time.
  4. Let go of the button to allow the router to restart.
  5. When all lights come back on, the reset has been completed.

After the reset, check if the DHCP error appears again.

If none of these troubleshooting tips work, you’ll need to contact your router’s support team.

If you’ve leased the router from your ISP, contact them instead, and they’ll take you through a set of possible fixes to the issue you’re having.

They might schedule an appointment with a technician if they can’t fix the issue over the phone.

For third-party routers, you do have a choice to send them back to the manufacturer for a replacement if its under warranty.

You May Also Enjoy Reading

  • Your ISP’s DHCP Does Not Function Properly: How To Fix
  • How to Change DNS Settings on Xfinity Router
  • 20/40 MHz Coexistence On Netgear Router: What Does This Mean?
  • Not Getting Full Internet Speed Through Router: How to Fix
  • Best Place to Put the Router in a 2-Story House

Frequently Asked Questions

What does APIPA is being used mean?

APIPA or Automatic IP Addressing is the alternate mode of allocating IP addresses to the devices on a network if DHCP is disabled.

Windows and some routers default to this protocol if DHCP was disabled and you set no static IP.

What happens when DHCP fails?

The effects of your DHCP server failing won’t become apparent immediately but will come up when your device asks for a new IP when the previous one times out or if there is a network change.

You can lose your internet connection if your DHCP server fails.

How do I enable DHCP?

You can enable DHCP from Windows network settings or your router’s admin tool.

Consult your router’s manual to know how to enable DHCP on it.

Is DHCP good for gaming?

Gaming on the internet relies on your ISP giving you an IP with their DHCP server, so you’ll be having it on anyway.

But if you’re playing on LAN, having static IPs are always preferred because IP addresses aren’t changing all the time.

Trouble Configuring DHCP Server/dhcp failed.apipa is being used

Hi, currently using Packet tracer i am trying to configure my Router for a DHCP Server (It is an optional task but would like to understand how it works). *I am trying to assign 20 PC’s with a IP Address between the range 175.200.0.225 — 175.200.0.254. *Whilst the network address is 175.200.0.224 and subnet of 255.255.255.224.

This is the config i am entering (Withing global config)
*int fa0/0
*ip address 175.200.0.225 255.255.255.224
*no shut   
*exit
*ip dhcp pool Admin   
*network 175.200.0.224 225.255.255.224   
*default-route 175.200.0.255   
*ip dhcp exclude 175.200.0.255 175.200.0.254 

Whenever i try to check the DHCP ip address of the 3 connect PCs (I will be adding
more) it says 'dhcp failed.apipa is being used' 
Anybody know why? or what i am not doing correctly? 

Понравилась статья? Поделить с друзьями:
  • Df646 ошибка рено дастер
  • Df645 ошибка рено мастер 3
  • Df645 ошибка рено дастер
  • Df644 ошибка рено
  • Df524 ошибка рено симбол